• <button id="fy02r"></button>
    <em id="fy02r"></em>

  •   虛擬主機域名注冊-常見問題數據庫問題 → 數據庫問題


    [原創]如何將Mysql數據庫如4.0X版升級為4.1/5.x版?
    作者:

    問:我原來的discuz論壇用的是php4.4+mysql4.0.18的數據庫,現在購買了你們的空間,服務器是php5.0+mysql5.0的.我直接把mysql數據庫的源文件導進來以后,發現論壇全部顯示????的亂碼,請問如何解決?

    答:myqsl4.0.x版的4.1/5.x版不兼容,不能直接用把mysql的源文件復制進來的方式,解決辦法有以下幾種:

    1.轉移服務器前,先在原服務器上,在論壇后臺點:系統設置>資料備份> 進行一次完整的數據備份.
    轉移服務器后,雖然是亂碼,但仍可以登錄后臺,在后臺系統設置>資料恢復> 用數據備份記錄中的 ***.sql進行一次恢復,即可解決亂碼問題.

    2. 可以下載第三方軟件如"帝國備份王": 下載地址: http://www.phome.net/ebak2/
    其功能有:
    系統自動識別MYSQL版本格式,然后進行轉換恢復。
    不同編碼數據庫之間可直接備份與恢復。
    系統支持完整備份,即使備份與恢復兩個數據表結構不一致,也可備份與恢復。
    下載后上傳到您的空間,配置完以后即可在線備份原來的4.0版的數據庫.

    備份完畢后,在"參數設置"中,改為新服務器的IP及用戶名和密碼,
    在"默認編碼"處選擇對應的編碼類型,如GBK,。╩ysql4.0不用選擇,但mysql5.0一般需要選擇。
    然后點"恢復數據"即可.
    恢復完畢即可解決亂碼問題. 關于"帝國備份王"的詳細使用說明請參看其官方網站說明:
    http://www.phome.net/ebak2/doc/docutf.html#usebak

    3. 申請由我司客服幫您升級.
    該服務收費100元/次,請支付款項后在有問必答提交申請,將由我司客服為您解決.


    本文本適用于任何php+mysql系統的版本升級問題.



    來源:
    閱讀:3628
    日期:2008/3/16

    【 雙擊滾屏 】 【 推薦朋友 】 【 收藏 】 【 打印 】 【 關閉 】 【 字體: 】 
    上一篇:已經沒有了。
    下一篇:已經沒有了。
      >> 相關文章
     
    天天操天天干